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Avista ™ Software Manual 

1 - Getting Started 
Welcome to Avista, the software designed for theatrical automation.  
Avista™ is built to make moving scenery easy and intuitive.  As 
today’s shows are increasingly complex, Avista™ offers a simple 
solution to bring the excitement of motorized scenery to every 
production.  By using a Windows® PC and standard Ethernet 
hardware, you can have a complete motion control system that is easy 
to set-up and incredibly economical.  Whether you need to move a 
deck winch, turntable, roll drop, or any other effect, Avista™ allows 
you to focus on the custom aspect of your production while providing 
a standard method of motion control. 

1.1 A word about safety 
The spectacle created by motorized scenery is fantastic.  Motion 
control allows huge scene changes to operate smoothly in a matter of 
seconds.  But this power deserves the utmost caution.  Unlike 
operating a computerized lighting console, or sound system, an 
automation system can pose a serious danger to performers and 
technicians.  Large pieces of scenery moving at high speed can easily 
injure, even fatally, any person that is unwittingly caught in its path.  
Therefore, a large responsibility is placed on the automation operator 
to be alert and aware of the people that may be in harm’s way. 
 
Avista™ assists the operator in maintaining safety by providing 
constant information of every motor’s position and status.  A hard-
wired emergency stop system, ShowStopper, provides an immediate 
way for the operator to shut down all the motion on the stage.  
Ultimately, it is the operator’s judgment and ability to see any 
potential hazards that will keep the show safe. 

1.2 System requirements 
To effectively use Avista™ you will need: 

1. A Windows® compatible PC (300 mHZ or faster) 
2. Windows® 2000 or better 
3. 10mb of free storage space 
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4. A network interface card (or built-in networking) 
5. An Ethernet hub 
6. Ethernet cables (1 for every device on the network) 
7. One or more Stagehand™ motor controllers with electric 

motors (winches, turntables, etc.) 
8. A ShowStopper™ emergency stop base station 

1.3 Installing AvistaTM 

To install Avista™: 
1. Insert the disc into your drive 
2. Navigate to My Computer and open the Avista disc 
3. Double-click Setup.exe 
4. Follow the on-screen instructions 

1.4 Configuring the AvistaTM  & StagehandTM 
network 
Avista™ can control any number of Stagehand™’s over a network.  I 
recommend that you setup a local network that is isolated from any 
other network in your facility to eliminate the possibility of network 
traffic affecting a performance. 
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The following diagram shows a typical network system for using 
Avista™.  Make sure that you have Ethernet cables connecting your 
PC and each Stagehand™ to an Ethernet hub (or series of hubs).  
Most Ethernet hubs will indicate if a proper hardware connection is 
made, which helps in finding damaged Ethernet cables. 

Figure 1.1 

 
 
The network uses static IP addressing, which means that you 
manually assign an IP address to every device on the network.  If you 
have already configured a Stagehand™, you know that setting its IP 
address is an easy process of pushing a button and turning a knob.  
Setting the IP address of your PC is only slightly more involved. 
 
To set the IP address of your PC: 

1. Click the Start button on your desktop 
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2. Open Control Panel 

 
3. Open Network Connections 
4. Right-click on the network adapter you wish to use and select 

Properties from the contextual menu 
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5. Scroll through the list and double-click on Internet Protocol 
(TCP/IP) 

 
6. Click Use the following IP address:  
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7. Enter an IP address such as 192.168.10.28 
8. Enter the subnet 255.255.255.0 
9. Click OK until you are back to the desktop 

 
At this point you may need to restart your PC depending on which 
operating system you are running. 

2 - Basic Motion Control Concepts 
From the perspective of an audience member motion control is magic.  
From the technician’s perspective it should not be magic.  Though the 
combination of Stagehand™ motor controllers and Avista™ software 
create a motion control system that everyone can use, it is important 
to know some basic concepts to avoid mistakes and help troubleshoot 
your system. 
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2.1 Power 
Depending on the model of Stagehand™ that you are using you need 
to supply either 120vac or 230vac single-phase power to each 
Stagehand™.  The Stagehand™ with convert this power into 
something suitable for your motor (either 90vdc or 180vdc).  The 
output voltage is varied to achieve variable motor speed. 
 
The Stagehand™ tracks the motor’s position and then relays that 
position to Avista™ to display on-screen.  If a Stagehand™ loses 
power, the next time it powers up it will reset its position to zero (0).  
This is very important, because if a motor is sitting 10’ from 
centerline and the power is interrupted, when the power comes back 
on the Stagehand™ will think that the motor is now at 0’ from 
centerline.  In this case, the motor needs to be driven back to the true 
0’ spike (usually a piece of spike tape or limit switch) and reset to 0’, 
either through Avista™ (using the Define Home button on the View > 
Motor Setup window) or by cycling power to the Stagehand™. 
 
The best operating procedure is to return all motors to zero (0) at the 
end of every performance.  If power is lost overnight when no one is 
around, then it won’t affect the Stagehand™’s position information.  
Otherwise, a pre-show check should be done to insure that every 
motor is truly at the correct position. 
 
Since all position information is stored in the Stagehand™, the PC 
running Avista™ can be shut down at any time without affecting 
position information whatsoever. 

2.2 Position Feedback 
How does the Stagehand™ know how to change speeds?  Good 
question.  There are two factors that affect the speed of a motor.  The 
first is the target speed that is programmed for each cue.  In Avista™ 
you tell each motor how fast to move in each cue.  This information is 
sent to the appropriate Stagehand™, which in turn supplies some 
voltage to the motor and watches to see what happens.  If the motor 
moves faster than the Stagehand™ expected, it reduces the voltage.  
If the motor moves slower than expected, the voltage is raised.  This 
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cycle continues at a rapid pace until the motor reaches the desired 
position. 
 
In order for the Stagehand™ to know how far and how fast the motor 
is moving in relation to the voltage it is supplying it needs an 
encoder.  An encoder is a simple device that creates electronic pulses 
as it spins.  The encoder is physically connected to the motor so that 
as the motor spins the encoder spins.  If the encoder were 
disconnected from the motor, the Stagehand™ would not see any 
movement regardless of whether the motor was actually rotating or 
not.  This could cause the motor to race, because the Stagehand™ 
would keep supplying more and more voltage to the motor hoping to 
see an increase in speed.  A similar situation would occur if the 
polarity of the motor was reversed from the encoder. 
 
There are safety features that you can set up to prevent a motor from 
racing, such as Max Position Error which tells a Stagehand to 
shutdown if it doesn’t get good response from the motor.  This feature 
is discussed in the chapter Setting Up A Show.  Later in this section 
Over-travel Limits are discussed as another safety precaution to guard 
against motor racing. 

2.3 Motor Tuning 
The cycle of watching encoder pulses and adjusting motor voltage is 
controlled by the tuning parameters of the Stagehand™.  These 
tuning parameters are often referred to as the PID filter, which stands 
for Proportional, Integral, and Derivative gains.  You enter numeric 
values for this filter into Avista™, which will then send the filter 
parameters to a Stagehand™.  While the mathematics of this filter is 
somewhat complex, the practical application is not.  We will walk 
through motor tuning in greater detail in the chapter Setting Up A 
Show.  It is worth mentioning that if you are using a PushStick™ 
winch or motor package from Creative Conners, Inc. there are preset 
tuning parameters that you can use which should work fine for the 
majority of situations. 

2.4 Over-travel Limits 
If the encoder position is wrong because of loss of power, physical 
disconnect from the motor, or some equipment failure, a physical 
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limit switch can be used to protect the motor from running too far.  
These limit switches, when struck, will prevent the motor from 
moving any farther in the detected direction (either forward or 
reverse).  The Staghand™ will only permit a movement in the 
opposite direction until the limit switch is cleared. 
 
Those are the basic principles of motion control, as you get more 
familiar with the operation of Avista™ and Stagehand™ these 
concepts with become more concrete and intuitive.  To get more 
familiar, let’s take a look at some of the features of Avista™. 

3 - AvistaTM interface overview 
Avista™ is comprised of five main windows that display information 
about the motors on your network and the cues that make those 
motors move.  The following section provides an overview of the 
interface elements and their purposes before diving into writing cues 
for a show.  If you just can’t stand the anticipation, go ahead and 
jump to the next chapter Setting up a Show, but come back when you 
need the details of a particular button or feature. 
 
To take a look at the interface, launch Avista™ from the Start menu.  
When Avista opens, you are presented with the main program 
window and the Motor Setup window.  Let’s look at the menu option 
in the main program window. 
 

3.1 Menus 
The Menus across the top of the main program window provide the 
following functions: 

1. File – The file menu is used for creating, saving and printing 
shows. 

a. New – Creates a new, blank show file. 
b. Open - Displays a dialog box that allows you to open 

an existing show file. 
c. Save – Saves the currently open show file. 
d. Save As – Saves the currently open show file with a 

new name. 
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e. Print – Prints a copy of the show with all motor and 
cue information. 

f. Exit – Closes Avista. 
2. Edit – The edit menu can be used to copy and paste text and 

cues just like you would a word processor. 
a. Copy – Can be used to copy text or cues. 
b. Paste – Can be used to paste text or cues. 

3. View – The different interface windows can be selected from 
the view menu. 

a. Cue Sheet – Displays a list of all the cues in the show.  
Cues can be added, deleted, linked, and copied in this 
view. 

b. Cue Spreadsheet – Displays a grid of all the cues and 
motors in the show.  Motor movements can be edited 
and whole cues can be added, deleted, and copied in 
this view. 

c. Cue Control – Displays the buttons used to load and 
run cues.  This is an on-screen duplicate of the controls 
found on the Showstopper. 

d. Manual Motor Control – Used to jog individual 
motors.  This replicates the controls found on each 
Stagehand. 

e. Stage Schematic – Displays a virtual stage where cues 
can be created and edited by dragging motors around 
with the mouse. 

f. Motor Setup – Displays a panel where motors can be 
added, edited, and deleted. 

4. Help 
a. Index – Provides an index of the online help manual. 
 

Beneath the Menu Bar, the Motor Setup window appears on start-up, 
so let’s take a look at that window first. 

3.2 Motor setup 
The Motor Setup window is where you set the various parameters that 
are unique for each motor that you will use in a show.  The 
parameters that you set in this window are constant for the entire 
show and won’t change for each cue.  Though these parameters aren’t 



Avista Software Manual 

Page 14 

changed during cues, they can be edited at any time so you don’t need 
to worry about locking in a specific value. 
 
Figure 3.1 

 
• The button bar at the top of the window allows you to: 

1. Add Motor – This adds a new motor to your show.  Add as 
many motors to your show file as you have physical 
motors on stage. 

2. Delete Motor – Removes a motor from the show if it 
becomes unneeded for any reason. 

3. Duplicate Motor – Creates a new motor that is a copy of 
the motor selected in the list.  This is useful if you have 
several motors on stage that have similar characteristics.  
You can set all the parameters on the first motor you 
create and then duplicate the motor as many times as you 
need, changing just the unique parameters. 

4. Define Home –This resets the motor’s position counter to 
zero.  You need to do this during the initial setup or any 
time you lose power to a Stagehand™.  Conceptually this 
is very important, the motor always counts position 
relative to the zero position so you need to make sure that 
what you consider position “zero” or home is accurate.  In 
practice this done by putting a piece of spike tape on the 
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stage floor and manually moving the motor to match that 
spike and then pressing Define Home. 

5. Export Tuning – Creates a motor configuration file (*.mtr) 
of the selected motor’s tuning parameters.  This file can 
then be imported into other show files allowing you to 
keep a stock of tuning parameters for your various 
mechanical effects (winches, turntables, etc.).  This is 
handy since the process of tuning a motor can be tedious. 

6. Import Tuning – Reads a motor configuration file (*.mtr) 
and applies the tuning in the file to the selected motor.  

 
• The list of motors beneath the button bar displays information 

about the motors currently defined for the show. 
1. Motor Name – This is the name that you give the motor.  

The name can be any combination of letter and numbers, 
typically a descriptive phrase like “SL Prop Wagon”. 

2. IP Address – The IP address of the motor, or more 
precisely the Stagehand that you want to control. 

3. Connection – Status of the network connection to the 
motor.  If everything is working this will read 
“Connected”.  If there is a network problem (cable 
unplugged, wrong IP address, etc.)  this will read 
“Closed”.  Note:  If you find a network problem that has 
prevented Avista from connecting to the motor press the 
Connect button to restart communication. 

4. Position – Shows the current position of the motor. 
5. Limits – Displays the status of both physical limit 

switches:   
a. All Clear – All Clear means that neither limit switch is 

engaged.   
b. Forward Limit – The forward limit is engaged. 
c. Reverse Limit – The reverse limit is engaged. 
d. Both Limits – If Both Limits are engaged either you 

placed the limit switches too close to one another, or 
more probable, one or both of the limits aren’t plugged 
into the Stagehand. 

 
Note: You can resize the Motor List by clicking and dragging the grey 
bar that separates the Motor List and the tabbed pane. 
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• Next to the list of motors is a tabbed pane that contains all of the 

parameters that can be configured for each motor.  To adjust a 
motor’s parameters, first select the motor from the list and then 
edit the configuration parameters in the tabbed pane.  While you 
usually set these parameters as the first step in beginning a new 
show, you can adjust these values at any time. 

1. TCP/IP tab 
a. IP Address – Enter the IP address for the Stagehand 

you wish to control.  The IP address is separated with 
periods, i.e. “192.168.10.32”.  Those of you that are 
network savvy may be asking “Where can I set the 
subnet mask?”  Well, you can’t.  The Stagehand’s 
subnet mask is set to “255.255.255.0” and isn’t 
configurable. 

b. Connection Status – Displays the network status for 
the selected motor.  “Connected” means everything is 
working, anything else means that you need to 
troubleshoot your network.  See the appendix on 
troubleshooting for some pointers. 

 
2. Properties tab 

a. Motor Name – In this box you can enter a descriptive 
name for the motor.  The name can be any 
combination of letters and numbers. 

b. Position Units – Natively, the Stagehand will send 
position information in encoder counts.  Typically, it 
isn’t convenient to program a show in encoder counts, 
instead you usually want to program movements in 
inches, or feet, or degrees, or millimeters, etc.  You 
can choose what units you wish to use from this drop-
down menu. 

c. Position Scale – In order for Avista to display the 
motor’s position in helpful units (like inches), you 
need to specify how many encoder counts there are per 
inch (or millimeter, or degree, etc.).  We’ll get into the 
process in greater detail later on, but suffice to say that 
the easy way to do this is move the motor manually 
(either using the jog controls on the Stagehand, or the 
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jog control in Avista).  See how many counts you 
moved, measure how for the motor traveled, and then 
divide the number of counts by the distance traveled. 

d. Maximum speed – This is the maximum speed you 
want to move the motor in Avista.  Speed values are 
always given in position units per second.  So if you 
are using inches as the position scale, speed will be in 
inches per second.  Of course, there are physical 
limitations to how fast your motor can move.  To 
discover the top speed of your motor, make sure it’s 
physically disconnected from any scenery and then run 
it at full speed using the job controls on the Stagehand.  
While moving, click the Maximum Speed button and 
Avista will read the speed of the motor.  This may be 
faster than you want to move the motor in the show, if 
so you can manually adjust the value to whatever you 
like. 

e. Forward Limit – This sets the software limit for the 
motor.  Entering a position here will prevent the 
operator from accidentally writing a cue beyond the 
desired travel on stage.  Avista also uses this value to 
calculate the length of the track when using the Stage 
Schematic.  To set the limit, either type in a value or 
press the Forward Limit button to use the motor’s 
current position as the Forward Limit. 

f. Reverse Limit – This sets the software limit for the 
motor.  Entering a position here will prevent the 
operator from accidentally writing a cue beyond the 
desired travel on stage.  Avista also uses this value to 
calculate the length of the track when using the Stage 
Schematic.  To set the limit, either type in a value or 
press the Reverse Limit button to use the motor’s 
current position as the Reverse Limit. 

g. Max. Position Error – This value is used to shutdown a 
motor automatically if the motor’s position isn’t 
keeping up with Avista.  This is a safety feature to try 
and detect problems with the motor (i.e. a mechanical 
jam, broken encoder, etc.)  The text field is used to set 
the “slop” allowable for the motor, and the checkbox 
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should be checked if you want Avista to automatically 
shut the motor down if the motor can’t keep up within 
the programmed “slop”.  The “slop” is necessary to 
accommodate things like cable stretch, play in the 
winch track, and less-than-perfect tuning.  Typically, 
theatrical mechanisms are a lot sloppier that high end 
robotics so you want to set the value high enough to 
prevent Avista from shutting down a motor that is 
performing OK. 

3. Tuning tab 
Tuning is the most intricate part of motion control.  
Though the underlying mathematics is complex, the basic 
premise is simple.  When a computer moves a motor it 
knows two things at any given time:  where the motor 
should be, and where the motor actually is.  The difference 
between these two values is known as the Position Error.  
To minimize the Position Error the computer is constantly 
adjusting the amount of power sent to the motor.  The 
magnitude of these adjustments is determined by the 
tuning parameters.  There is a tutorial on motor tuning 
later in this manual. 
a. Proportional Gain – This gain setting adjusts how hard 

the motor will try and correct for position errors.  Too 
low of a value will cause the motor to appear sluggish, 
too high and the motor will over-compensate for the 
position error and jerk back and forth. 

b. Derivative Gain – This gain setting provides a damping 
to smooth jerky motion.  The damping is applied 
against the rate of change in position error.  While 
proportional gain keeps a steady amount of power to 
combat position error, derivative gain will increase the 
amount of power if the position error is accelerating. 

c. Integral Gain  – This gain setting is similar to 
proportional gain, it provides a constant ratio of power 
against position error.  Unlike proportional gain, the 
force will increase over time.  In other words, the 
longer the position error is detected, the more 
corrective force will be asserted.  Integral Gain is 
touchy, and seldom has much use in theatrical 
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applications.  It is a very fine-tuned adjustment that is 
more typical used with precise mechanisms. 

d. Integral Limit – This setting provides a ceiling for the 
amount of corrective force that the Integral Gain can 
generate.  This prevents integral wind-up, which is a 
backlash effect.  Like Integral Gain, Integral limit is 
seldom used in theatrical applications. 

e. Sampling – The sampling setting determines how 
frequently position error is checked and corrected.  
This value is a multiplier of the Stagehand’s internal 
timing cycles.  Typically the sampling rate is between 
1 and 10. 

4. Advanced Tab 
a. The two-column list is a detailed view of the 

Stagehand status.  This report can be useful in 
troubleshooting Stagehand problems if you are on the 
phone with technical support. 

b. Reset Drive – This button will cycle power to the 
embedded motion controller inside the Stagehand.  
This can be used to in troubleshooting a Stagehand, it 
allows a drive to be reset without having to physically 
cycle power to a Stagehand. 

5. Schematic tab 
The parameters in the Schematic tab are used to adjust the 
way the motor is viewed on the virtual stage in the Stage 
Schematic. 
a. Distance from Plasterline – This is the distance from 

plasterline to the center of the track for a winch, or the 
center of a turntable.  You can type in a numerical 
value in this text box, or adjust the position graphically 
in the Stage Schematic. 

b. Distance from Centerline – This is the distance from 
centerline to the reverse limit of the track for a winch, 
or the center of a turntable.  You can type in a 
numerical value in this text box, or adjust the position 
graphically in the Stage Schematic. 

c. Wagon Width – The approximate width of the actual 
wagon that is connected to a winch.  This value will be 
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used to display a graphic of the wagon on the virtual 
stage in the Stage Schematic. 

d. Wagon Length – The approximate length of the actual 
wagon that is connected to a winch.  This value will be 
used to display a graphic of the wagon on the virtual 
stage in the Stage Schematic. 

e. Turntable Diameter – This box is only visible when the 
Turntable option is selected below.  Enter the 
approximate diameter of the turntable, this value will 
be used to display a graphic of the wagon on the 
virtual stage in the Stage Schematic. 

f. Motor Type – Select either winch or turntable to 
control the way the graphic representation of the motor 
is displayed in the Stage Schematic.  Winches are 
shown as a rectangular wagon with a winch track.  
Turntables are shown as a circle with a rotating pie 
section. 

• Underneath the tabbed view are three buttons:  OK, Cancel, & 
Apply. 

1. OK – Records any changes made to the motor parameters 
and closes the window. 

2. Cancel – Throws out any changes made to the motor 
parameters and closes the window. 

3. Apply – Records any changes made to the motor 
parameters and leaves the window open for further 
editing.  You must click apply to save any parameter 
changes before clicking on a new motor in the motor list.  
If you don’t, a dialog box will ask if you want to save the 
current changes before editing a different motor. 

3.3 Cue spreadsheet 
The Cue Spreadsheet offers a numerical view of the cues in the show.  
The data is presented in a table where columns are cue numbers and 
rows are motor movements.  This view gives an easy look at the 
entire show, which allows you to see quickly which motors are 
programmed to move in a specific cue and to edit the movement. 
 

Figure 3.2 
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• At the top of the window is a button bar with two buttons: 

1. Add Cue  – Creates a new cue.  After you press the button 
a dialog box with ask you for a cue number to be assigned 
to the new cue.  Cue numbers can be any numeric value 
(i.e. 10, 510, 3.1, 4.24254).  Cues can be added at any 
time, in any order.  For instance if you write a cue 4 & a 
cue 5 only to discover that you need a cue 4.5, just add it 
in and it will be inserted between cue 4 & 5 automatically. 

2. Delete Cue – Deletes the selected cue from the show.  This 
will delete all of the motor movements for the cue and 
remove the cue from the show 

• Beneath the button bar is the table that contains all of movements 
in the show.  The table is organized to provide cue information in 
an easy-to-read format. 

1. Grey Columns – The first two columns have a grey 
background and cannot be edited directly.   

a. The first column displays each motor by name.  
The name of the motor can be edited in the Motor 
Setup, see the previous section for details.   

b. The second column provides four pieces of 
information for each motor: 

i. Status – This box shows the status of the 
motor (Fwd Limit, Rev Limit, Loaded, 
Running, Idle, Complete, Fault, Stopped, 
E-Stop, Connected, Not Connected) 

ii. Position – Displays the current position of 
the motor, scaled to the value set in the 
Motor Setup.  This is also a row label for 
the cells on the right.  The white cells on 
the right display where the motor will move 
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to in each cue.  These values can be edited 
directly. 

iii. Speed – A row label for the white cells.  
The white cells on the right display the 
speed of the motor in each cue.  These 
values can be edited directly.  The values 
are in scaled units per second (i.e. inch per 
second, degree per second, etc.) 

iv. Acceleration – A row label for the white 
cells.  The white cells on the right display 
the acceleration of the motor in each cue.  
These values can be edited directly.  The 
values are in scaled units per second per 
second (i.e. inch per second per second, 
degree per second per second, etc.) 

2. Grey row – The top row of grey cells contain the cue 
numbers for each cue in the show.  These numbers are 
set as you create each cue.   
 
You can copy/paste entire cues from cue to another.  
Click on the cue number to select the entire cue.  Select 
Edit>Copy from the menu, or press Ctrl+C.  Click on the 
cue you wish to paste into and select Edit>Paste from 
the menu or press Ctrl+V.   
 
If you find that you need to change a cue’s number, you 
can easily create a new cue, copy the old cue into the 
new cue, and then delete the old cue.  Alternatively, you 
can change the cue number in View>Cue Sheet>Cue 
Properties. 
 
To load a cue, double-click on the cue number.  This 
will send the cue information to each motor in the cue 
and place the motors on standby. 
 

3. White Cells – There are five types of white cells in the 
main area of the spreadsheet: 

a. Cue Name – The top row of white cells contains a 
descriptive name for the cue.  This cell is blank by 
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default.  To change the cue name, click on the top 
cell and type in a name.  When finished, hit Enter, 
Tab, or click on another cell. 

b. Motor Movement Status – The row of cells that 
align with the motor names in the grey cells report 
the status of the motor’s movements in each cue.  
The status will be either: 

i. Loaded – The motor has received a cue 
from Avista and is ready to start. 

ii. Running – The motor is currently moving 
towards the position programmed for this 
cue. 

iii. Complete – The motor has finished moving 
to its position. 

iv. Idle – The motor is awaiting instruction for 
movement. 

v. Stopped – The motor has been stopped 
before reaching its target position.  The 
motor could have been stopped by 
Showstopper, a limit switch, or the on-
screen stop button. 

To remove just one motor from a cue, click on the 
Motor Movement Status and press Backspace. 

c. Position – These cells contain the target position 
for the motor in each cue. To edit the target 
position just click on the cell and type in a new 
value.  Then hit Enter. 

d. Speed – These cells contain the speed for the 
motor in each cue.  To edit speed values, simply 
click on the cell and type in a new value.   Then hit 
Enter. 

e. Acceleration - These cells contain the acceleration 
for the motor in each cue.  To edit acceleration 
values, simply click on the cell and type in a new 
value.   Then hit Enter. 

4. Colors – The spreadsheet cells are color coded to give 
quick visual feedback regarding the status of each motor 
in each cue.  The background color of a cell will change 
depending on the current status of a motor in a cue. 
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a. White – A white cell indicates that the motor is 
idle. 

b. Red – A red cell indicates that the motor is loaded 
with a cue. 

c. Green – A green cell indicates that the motor is 
running a cue. 

d. Blue – A blue cell indicates that the motor has 
finished running a cue to completion. 

e. Yellow – A yellow cell indicates that the motor has 
been prematurely stopped while trying to complete 
a cue.  The reason for the motor stopping is either: 
E-Stop, a stop command from either the on-screen 
Cue Control or Showstopper, a limit switch is 
engaged, or Max Position Error was reached. 

You can copy/paste between any editable cells in the 
spread sheet view.  To copy a range of cells, select all 
the cells you wish to copy and choose Edit>Copy from 
the menu or press Ctrl+C.  Select the top left cell of the 
range you’d like to paste the copied cells into and 
choose Edit>Paste from the menu or press Ctrl+V. 
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3.4 - Cue Sheet 
The Cue Sheet presents the cues in the show in a tree view.  This 
offers an overall picture of the cues and the flow of the show.  From 
this view cues can be linked to each other to create complex, 
automated cue movements. 

    Figure 3.3 

 
 
• At the top of the Cue Sheet is a button bar for common cue 

manipulation tasks. 
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1. Add Cue – Creates a new cue and prompts you for a cue 
number.  This has the same effect as the Add Cue button 
on the Cue Spreadsheet. 

2. Delete Cue – Deletes the selected cue from the show.  This 
has the same effect as the Delete Cue button on the Cue 
Spreadsheet. 

3. Duplicate Cue – Creates a copy of the selected cue.  A 
dialog box will then prompt you for a new cue number to 
store the copied cue. 

4. Break Link – Breaks the link between two cues.  Select the 
child cue, the cue furthest indented, and then click the 
break link button.  The link is broken and the child cue is 
returned to an independent cue 

• Beneath the button bar is the tree view that lists all the cues in a 
hierarchy that depicts both the order and links of the cues. 

1. Click on a cue – Click on a cue to select the cue.  This 
allows you to edit values in the Cue Properties pane 
below.  If the cue is linked, you can now break the link 
with the Break Link button above. 

2. Double-click on a cue – Double-clicking on a cue will load 
the cue, sending cue information to all relevant 
Stangehands and put the motors on standby. 

3. Drag-and-drop – Click and drag a cue onto another to link 
the two cues together.  The cue that you drag will become 
the child cue, meaning that it will be driven by the cue that 
you dropped it on.  You can adjust how the link works 
with the settings in the Cue Properties pane below. 

4. Colors – Next to the cue name, a color-coded icon will 
appear when running cues to give a quick status report. 

a. Red – A red light bulb indicates that the cue is 
loaded and will be started whenever the Go button 
is pressed on the Cue Control or on Showstopper. 

b. Green – A green light bulb indicates that the cue is 
currently running. 

c. Blue – A blue light bulb indicates that the cue has 
completed all of its movements. 

d. Yellow – A yellow light bulb indicates that the cue 
has been stopped prematurely.  This could indicate 
an emergency stop, motor fault, or limit switch. 
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• Beneath the tree view is the Cue Properties pane.  To access the 
properties of the cue select it in the tree view above. 

1. Cue Number – Here you can change the number of the 
selected cue.  After entering a new value press Enter to 
record the change. 

2. Cue Description – Enter a descriptive name for the cue, 
this can help you identify cues more easily than just the 
cue numbers.  After entering a new value press Enter to 
record the change. 

3. Link Status – If a cue is linked to another cue, the parent 
cue’s number will be displayed here. 

4. Link type drop down list – For a linked cue, choose which 
type of link you want: 

a. Independent – Setting a link to independent will 
break the link. 

b. Completion – The child cue will start directly after 
the parent cue completes all of its movement. 

c. Time Trigger – The child cue will start at a 
programmed number of seconds after the start of 
the parent cue. 

d. Position Trigger – The child cue will start when a 
specific motor in the parent cue reaches a certain 
position.  When this link type is selected another 
drop down list appears to allow you to select which 
motor in the parent cue will drive the child cue. 

e. Link parameter – For time trigger cues this box 
contains the number of seconds between the start 
of the parent cue and the start of the child cue.  For 
position trigger cues this box contains the position 
of the motor in the parent cue that will trigger the 
start of the child cue.  After entering a new value 
press Enter to record the change. 

3.5 - Stage Schematic 
The Stage Schematic is unique feature in Avista.  It provides a virtual 
stage to let you write cues visually, positioning motors graphically 
instead of keying in numbers.  The Stage Schematic shows a plan 
view of typical proscenium theatre, which can be adjusted to 
resemble your own theatre.  Motors are then positioned on the plan 
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view to approximate their actual positions on your stage.  Motors are 
shown as either winches or turntables, depending on the setting in 
Motor Setup > Schematic tab. 

Figure 3.4 

 
• At the top of the Stage Schematic is a button bar that provides 

tools for adjusting individual motors and cues. 
1. Select – When depressed, this button allows you click on any 

winch or turntable to select it.  If you want to select more than 
one winch or turntable hold the Shift key down while clicking.  
Objects that are selected will have a red outline.  To deselect 
all objects, click on a blank part of the virtual stage. 

2. Move – When depressed you can move the graphics on the 
stage.  Click anywhere on the stage and the selected winches 
and turntables will move to the cursor.  For winches the 
reverse limit of the track (marked with a small circle) will 
snap to the cursor.  For turntables, the center of the turntable 
will snap to the new cursor.  This does not move the position 
of the motor in a cue, it is used to place the graphics on the 
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virtual stage.  To change the position of a motor in a cue, use 
the Set Target tool.  

3. Rotate – This tool lets you rotate the winch tracks of winches 
to orient them to some other angle than parallel to plasterline.  
Select the motors you want to rotate, then click Rotate.  To 
define a new rotation angle takes three clicks: 
a. Click on the stage to define an base point for the new 

rotation. 
b. Move away from the base point and click to define a 

baseline for the rotation.  As you move the mouse you’ll 
see a dotted guide line. 

c. Rotate to the new position and click. 
4. Set Target – This tool lets you set the target position for a 

motor in a cue.  With a cue loaded, select the motor you wish 
to set a target for.  Click on Set Target, then click and drag 
anywhere on the virtual stage.  Dragging to the right will 
increase the target position, dragging to the left will decrease 
the target position.  As you drag the mouse you will see a grey 
shadow of the wagon or turntable moving.  This grey shadow 
represents the target position.  After you have set all of the 
targets, press the Apply button at the bottom of the window to 
record the changes, or press Cancel to throw away the 
changes. 

5. In Cue – For a motor to move in a cue, it must be included in 
the cue.  The In Cue button includes the selected motors in the 
currently loaded cue.  With a cue loaded, select the winches or 
turntables you want to have in the cue and then depress the In 
Cue button.  To remove a winch or turntable from a cue, click 
on the In Cue button to release it.  Once a motor is in a cue, 
you still need to program target, speed, and acceleration in 
order for the motor to actually move when the cue is run. 

6. Add Cue – Clicking on this button will add a new cue to the 
show.   A dialog box will prompt you for a new cue number. 

7. Copy Cue – Clicking on this button will copy the movements 
of the currently loaded cue to the clipboard. 

8. Paste Cue – Clicking on this button will paste the any 
movements from the clipboard to the currently loaded cue. 

9. Delete Cue – To remove a cue from the show, load the cue and 
press this button. 
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• Beneath the toolbar is a series of drop-down lists and text boxes, 
called the Display Bar, where you can load and edit cues. 
1. Load Cue – Select a cue from the drop-down list to load it and 

display the cue on the virtual stage. 
2. Motor – Select a motor from the drop-down list to select it on 

the virtual stage.  This is an alternative to selecting the motor 
using the Select tool in the button bar. 

3. Target – This box will display the current target for the last 
selected motor in the loaded cue.  You can edit the target by 
typing in a new value, to record the changes press the Apply 
button at the bottom of the window, or press Cancel to throw 
away the changes and revert to the previous version of the 
cue. 

4. Speed – This box will display the current speed for the last 
selected motor in the loaded cue.  You can edit the speed by 
typing in a new value, to record the changes press the Apply 
button at the bottom of the window, or press Cancel to throw 
away the changes and revert to the previous version of the 
cue. 

5. Accel – This box will display the current acceleration for the 
last selected motor in the loaded cue.  You can edit the 
acceleration by typing in a new value, to record the changes 
press the Apply button at the bottom of the window, or press 
Cancel to throw away the changes and revert to the previous 
version of the cue. 

6. X – The current horizontal cursor position is displayed here. 
7. Y – The current vertical cursor position is displayed here. 

• Beneath the Display Bar is a tabbed pane that shows the virtual 
stage on the Schematic View tab, and basic stage parameters on 
the Stage Properties tab. 
1. Schematic View tab 

a.  Hatched perimeter – The hatched perimeter represents the 
walls of your theatre, just as in plan view drawing.  There 
is a centerline and plasterline placed on the drawing to 
provide some reference lines between your real theatre 
and the schematic on screen. 

b. Winches – Winches are displayed on the virtual stage as a 
wagon that slides along a winch track.  The graphic has 
four basic elements: 
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i. Wagon – The wagon is drawn as a rectangle.  The size 
of the rectangle can be adjusted in the View>Motor 
Setup>Schematic tab. 

ii. Reverse Limit – The reverse limit is shown as a small 
circle. 

iii. Forward Limit – The forward limit is shown as a small 
X. 

iv. Winch Track – The winch track is drawn as a line that 
connects the reverse limit and forward limit.  To 
change the length of the track, edit the forward and 
reverse limit values found in View>Motor 
Setup>Properties. 

c. Turntables – Turntables are displayed on the virtual stage 
as a circle with a wedge that points towards the turntable’s 
current position.  The graphic has two basic elements: 
i. Turntable – The diameter of the turntable is shown as a 

circle.  To change the diameter of the turntable adjust 
the Turntable Diameter found in View>Motor 
Setup>Schematic. 

ii. Pointer – The pointer is shown as a triangular wedge.  
As the turntable rotates the pointer will rotate to 
display the current position of the turntable. 

2. Stage Properties tab –The values entered on the Stage 
Properties tab control how big the stage looks on the 
Schematic View. 
a. Units of measure – Select a unit of measure that you want 

to use when entering the dimensions of your theatre. 
b. Stage Width – Enter the approximate width of your theatre 

from SL Wing to SR Wing. 
c. Stage Depth – Enter the depth of your stage from the 

plasterline to the US wall. 
d. Proscenium Opening – Enter the width of your 

proscenium opening. 
Note:  Obviously not everyone works in a traditional 
proscenium space, just enter values that give you a close 
approximation of the available playing area. 
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3.6 - Manual motor control 
The manual motor control makes jogging motors to an arbitrary 
position easy without having to be in front of a Stagehand. 
 

Figure 3.5 

 
1. Motor – From the drop-down list select which motor you’d 

like to move. 
2. Position – This box will display the position of the motor 

as it is being moved in its scaled units.  This allows you to 
either place the motor at an exact position, or move the 
motor to a spot on stage where it is visually correct and 
note the position number.  The unit scale can be adjusted 
in View>Motor>Setup>Properties. 

3. Speed – This box will display the current speed of the 
motor in units/second.  The unit scale can be adjusted in 
View>Motor Setup>Properties. 

4. Forward/Reverse – Select which direction you want to 
move the motor. 

5. Speed Slider – The slider bar controls how fast to move 
the motor.  Click and drag on the slider to move the motor, 
whenever you release the mouse button the motor will 
instantly stop.  This is a safety feature to insure that the 
operator is always at the controls when a motor is moving. 

4 - Setting up a show 
With the description of the interface finished, let’s get our hands dirty 
and set up a show to see how to put all of these aspects of the 
software to use.   
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4.1 – Network Setup 
Before launching Avista, make sure you have connected all of your 
Stagehands and your PC to a network hub.  Also make sure that all 
Stagehands are connected to Showstopper, and Showstopper shows a 
System Ready light.  For sake of this example, I’ll use two Stagehands 
and a PC with the IP addresses: 

1. PC – 192.168.10.28 
2. Stagehand #1 – 192.168.10.31 
3. Stagehand #2 – 192.168.10.32 

 
If you skipped over Configuring Avista and Stagehand Networks 
earlier in this manual, here’s the process for configuring the IP 
address on your PC. 
To set the IP address: 

1. Click the Start button on your desktop 
2. Open Control Panel 
3. Open Network Connections 
4. Right-click on the network connection you wish to use and 

select Properties from the contextual menu 
5. Scroll through the list and double-click on Internet Protocol 

(TCP/IP) 
6. Click Use the following IP address: 
7. Enter an IP address such as 192.168.10.28 
8. Enter the subnet 255.255.255.0 
9. Click OK until you are back to the desktop 

 
At this point you may need to restart your PC depending on which 
operating system you are running. 
 
To set the IP address of the Stagehand: 

1. Push the knob on the face of the Stagehand, this will bring up 
the IP configuration menu. 

2. Rotate the knob until the cursor is in the last segment of the IP 
address. 

3. Push the knob to edit the address. 
4. Rotate the knob up or down until you have the correct 

address. 
5. Push the knob to record the address. 
6. Rotate the knob until the cursor is flashing on OK. 
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7. Push the knob. 
8. The display should now read:  

a. “Not Connected” 
b. “192.168.10.31” (or whatever address you selected) 

If the display reads “Emergency Stop!” check that all connections to 
Showstopper are made and that you have a System Ready light on 
Showstopper.  If the display reads “Forward Limit!”, “Reverse 
Limit!”, or “Both Limits!” check your limit switch connections.  
Make sure the limits are all wired Normally Closed. 
 
With the basic hardware setup finished, launch Avista from the Start 
Menu.  When Avista starts up you will see the Motor Setup window 
with a blank list of motors.  So the first step is to configure your 
motors. 
 

4.2 –Configuring motor parameters 
In order to configure motors, you first need to add them to the show.  
In our example we are using two Stagehands with motors attached.  
To add two motors, click the Add Motor button twice. 
 

Figure 4.1 
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4.2.1 – Setting the IP address 
To set the IP address of both Stagehands: 

1. Click on “Motor 1” in the Motor List. 
2. In the TCP/IP pane of the tabbed view, enter 192.168.10.31. 
3. Press the Connect button.  The Connection status should 

change to “Connecting” and then “Connected” almost 
instantly.  If the status does not change to Connected, check 
your network cabling and your PC’s network settings. 

4. Click on “Motor 2” in the Motor List. 
5. Repeat steps 2 & 3, except use 192.168.10.32 as the IP 

address. 
 
You now have both motors connected to Avista, before we set up any 
further parameters let’s do a quick check to make sure your motor is 
working properly. 

4.2.2 – Testing the motor 
To test the motor, first make sure the motor is not connected to any 
scenery.  If the polarity of the motor isn’t correct, or the encoder is 
hooked up right, you could see a violent reaction from the motor.  
This is harmless, so long as nothing heavy is attached to the motor.  
Make sure you disconnect any load from the motor before 
continuing. 
 
Let’s make sure that the polarity of the motor is correct, so that when 
the computer tries to drive the motor forward, the motor moves 
forward not reverse. 

1. Open View>Manual Motor Control. 
2. Select Motor 1 from the Motor drop-down list. 
3. Select Forward. 
4. Slowly raise the speed slider until you see the position 

numbers changing. 
5. If the numbers in the Position box are getting bigger, then the 

motor is moving forward.  If not, the motor is moving in 
reverse.  To correct the direction of the motor let go of the 
speed slider and go swap the black and white wires in the 
motor plug.  For more information see the Stagehand manual. 
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6. Assuming that you have the motor spinning correctly, lower 
the speed on the speed slider until the motor stops.  Release 
the speed slider and now select Reverse. 

7. Slowly raise the speed slider until you see the position 
numbers changing. 

8. If the numbers in the Position box are getting smaller, then the 
motor is moving in reverse.  If not, fix the polarity of the 
motor as described in step 5. 

9. Repeat steps 2-8 except select Motor 2 from the drop down 
list. 

 
With both motors tested, we’re ready to begin setting the rest of the 
parameters in the motor setup panel.  Close the Manual Motor Control 
and open View>Motor Setup, if it’s closed. 
 

4.2.3 –Tuning a motor 
The best opportunity to tune a motor and get a feel for the tuning 
process is before the motor is attached to a speed reducer or any other 
equipment.  Ideally you set the motor on a bench with the encoder 
attached and have the motor shaft within reach as you adjust tuning 
parameters from Avista.  This is the first method of tuning that I’ll 
outline.  The second method of tuning is with the motor already in 
service, which we’ll discuss after setting up some of the other motor 
parameters. 
 
I like to think of tuning a motor as an analogy to building a cruise 
control for a car.  You want the car to stay at a 65mph on its trip, but 
to maintain that speed you need to constantly adjust the amount of 
fuel supplied to the engine.  If you are going up a hill, you need more 
fuel.  If you are coasting down a hill, you need less fuel.  If the cruise 
control adjusts too much and goes above 65mph it has to let off the 
gas and coast back down.  Following that analogy, Proportional Gain 
is the amount of gas supplied to correct the speed.  Too high a value 
and the car will be jerky as it bounces between 60mph up to 70mph 
and then back down to 60mph.  Too low a value and the car won’t 
maintain 65mph going up a hill.  Derivative Gain can be though of as 
a shock absorber attached the gas pedal, it smoothes out the jerkiness 
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of the Proportional Gain corrections.  Sampling is how often the 
cruise control checks the speed on the wheels. 
 
Before we begin tuning, the three main settings that will be adjusted 
are: 

1. Derivative Gain – Derivative Gain applies a damping force to 
the shaft of the motor.  It applies more force as the rate of 
position error increases.  So the faster you turn the motor shaft 
by hand, to more resistance you’ll feel.  You want Derivative 
Gain to be as high as possible without motor vibration.  
Typically you start increase Derivative gain by 50 until you 
observe motor vibrations and then you back off a little. 

2. Sampling – Sampling controls how often the Stagehand 
updates the position error and applies the corrective action.   
Like Derivative Gain, this value should be as high as possible 
(though it is rare to have a Sampling value above 5). Typically 
you start with a Sampling of 1 and increase by 1 until you 
observe motor vibrations and then back off a little. 

3. Proportional Gain – Proportional Gain applies a corrective 
force proportional to the position error.  Where Derivative 
Gain will only affect the rate of change in position error, 
Proportional Gain will actively try to push to motor back to 
the target position.  If Proportional Gain is too low the motor 
will not have enough power to fully correct its position.  If 
Proportional Gain is too high, the motor will over-compensate 
for the position error and oscillate as it continually overshoots 
its target. 

 
Tuning settings can vary widely depending on the motor and encoder 
used.  For reference, when I tuned a 2hp motor with a 60ppr encoder I 
had the values:  Proportional Gain = 36, Derivative Gain = 4000, 
Sampling = 1.   
 
Alright, if you are sitting beside your motor with an encoder attached, 
let’s get started. 

1. With Avista open, make sure the Motor Setup panel is visible 
(View>Motor Setup) 

2. Select Motor 1 from the Motor List 
3. Click on the Tuning tab 
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4. Enter a Derivative Gain of 50 and a Sampling of 1. 
5. Click the Load Filter button.  This sends the new tuning 

parameters to the Stagehand 
6. Click Start Zero-Speed Move, this sends a cue to the 

Stagehand to disengage the brake and try and hold the motor’s 
current position. If the motor starts to jerk violently during 
tuning, click Kill Move, readjust the parameters and click Load 
Filter and Start Zero-Speed Move again. 

7. Turn the motor shaft by hand in both directions.  You should 
feel more resistance the faster you turn. 

8. If the motor is jerking as you turn the shaft go to step 9, 
otherwise increase Derivative Gain by 50 and go to step 5. 

9. Increase Sampling by 1 and try turning the shaft by hand, if 
the jerking is minimal, increase Derivative Gain by 50 and go 
to step 5.  Otherwise continue. 

10. Reduce Derivative Gain by 10 and press Load Filter. 
11. Turn the motor shaft by hand, if the jerkiness is minimal 

proceed to step 12.  Otherwise repeat steps 10 & 11. 
12. Raise Proportional Gain by 5. 
13. Click Load Filter. 
14. Try turning the motor shaft by hand. 
15. If the shaft doesn’t spring back to its original position when 

you release it, then go back to step 12. 
16. If the shaft springs back and then starts jerking back and forth, 

reduce Proportional Gain by 1 and click Load Filter.  Test by 
turning by hand, and repeat until the shaft stops jerking. 

17. If the shaft springs back to its original position when you 
release it and doesn’t jerk back and forth, then you are done. 

18. Press Kill Move to engage the brake and shut the motor off. 
19. Press Apply to save these settings. 

 
If you have a stock of the same motor and encoders, you should click 
the Export Tuning button on the button bar and save the tuning 
parameters to a separate file.  This will allow you to use Import 
Tuning to select the same tuning parameters for every show.   
 
Depending on the loading of the motors, these values my have to be 
adjusted as you start writing cues.  Generally, lowering Proportional 
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Gain will reduce the jerkiness of a motor, while raising it will 
increase its ability to maintain proper speed. 
 

4.2.4 – Setting general motor information 
1. With the Motor Setup window open, click on Motor 1 in the 

motor list. 
2. Click on the Properties tab. 
3. In the Motor Name box enter SL winch (or whatever you like). 
4. Select “inches” from the Position Units drop-down list. 
5. To set the position scale, you may want to get a helper just to 

keep from having to run back and forth between your PC and 
the piece of scenery your moving. 

a. Connect the scenery to the motor. 
b. Open View>Manual Motor Control, leave Motor Setup 

on screen as well. 
c. Move the scenic piece slowly in reverse until you get 

to the furthest reverse position you’ll use in the show.  
This should be at least 6” away from your physical 
limit switch. 

d. On Motor Setup press Define Home.  This will reset the 
motor’s position to zero. 

e. Place a piece of spike tape on the floor to mark the 
scenery.  You will want to keep this spike tape for the 
run of the show to check position periodically. 

f. On Manual Motor Control, move the scenic piece 
slowly in forward until it reaches the furthest forward 
position you’ll use in the show.  This should be at least 
6” away from the physical limit switch. 

g. Note the position of the motor, in either the Manual 
Motor Control Position box or in the Motor List on the 
Motor Setup window.    This number represents the 
encoder counts that the motor just moved. For this 
example I’ll use 150000 encoder counts, though your 
number may be different. 

h. Now measure how far the scenery moved from your 
spike tape in inches.  For this example I’ll use 363 ½”, 
your number may be different. 
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i. Position Scale = encoder counts / inches.  So in our 
example position scale is 150000 / 363.5 which is 
412.65.  Calculate your own position scale using the 
numbers you have collected. 

j. Enter the position scale in the Position Scale box and 
press Apply.  Avista automatically rounds the number 
to get rid of any fraction. 

6. To enter the Maximum Speed, have your helper run the 
motor using the jog controls on the Stagehand.  Press and 
hold the FWD button and turn the knob up (for more info 
consult your Stagehand manual).  Run the motor at the 
maximum speed you want to use in the show.  While the 
Motor is moving press Maximum Speed.  Slow the motor 
to a stop.  For this example I’ll use a maximum speed of 
29 inches/second. 

7. To enter the Forward Limit, move the scenery to its most 
forward position and press the Forward Limit button.  
Avista will read the current position as the Forward Limit.  
If you need to tweak this number, edit the number in the 
box.  The forward limit is shown in the same units as the 
position scale (inches, feet, etc.) 

8. Enter 0 in the reverse limit box. 
9. Leave the Max. Position Error unchecked for the moment.  

We’ll adjust this value after the motor has been tuned. 
10. Press Apply. 

4.2.5 –Settings for Stage Schematic 
One of the exciting features of Avista is the Stage Schematic, a 
virtual stage where you can graphically write cues by the positioning 
motors with the mouse rather than keying in numbers.  In order for a 
motor to be properly represented in the Stage Schematic, you need to 
set up a few basic parameters. 

1. Select View>Motor Setup>Schematic tab 
2. Select the Motor Type, either Winch or Turntable.  Note:  You 

can use the Winch type for any linear mechanism and the 
Turntable for any rotary mechanism. 

For Winch Motor Type: 
3. Enter the approximate Wagon Width of the scenery you are 

moving. 
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4. Enter the approximate Wagon Length of the scenery you are 
moving. 

5. Click OK. 
For Turntable Motor Type: 
6. Enter the Turntable Diameter. 
7. Press OK. 
8. Select View>Stage Schematic>Stage Properties tab 
9. Select your units from the Units of Measure. 
10. Enter in the approximate Stage Width, Stage Depth, & 

Proscenium Opening. 
11. Press Apply. 
12. Select the Schematic View tab. 
13. You should now see a plan view of a stage with your motors 

downstage center. 
14. Use the Select & Move tools to move the motors to match 

their positions on your real stage.  For accurate positioning of 
winches and turntables use the View>Motor Setup>Schematic 
tab. 

We know have a show file set up and configured.  Before you go on 
to writing cues, take a moment to save the file using File>Save As… 
 

4.2.6 – Tuning a Motor that is in Service 
If weren’t able to tune your motor on a bench, disconnected from any 
mechanics, follow these steps to tune the motor while attached to 
scenery.  If you were able to complete the tuning process in 
section 4.2.3, then skip ahead to the next section. 

1. First we will write two cues to move the motor back and 
forth as we test our tuning progress.  The goal is to get the 
motor to move back and forth smoothly and have it hit the 
targets accurately. 

a. Open View>Stage Schematic 
b. Click on the Stage Properties tab 
c. Enter the approximate dimensions of your theatre. 
d. Click on the Schematic View tab 
e. Select SL winch, or whatever you named Motor 

#1, from the drop down-list.  You should see the 
winch highlighted with a red outline. 

f. Click on the Move tool in the button bar 
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g. Click a spot on the stage that is close to the real 
position of the winch track.  The winch graphic 
should snap to your mouse click. 

h. Click the Add Cue button, and enter a 1 for the cue 
number. 

i. Select Cue #1 from the Load Cue drop-down list.  
This loads the cue into the Stagehands and onto the 
virtual stage. 

j. To place Motor #1 in the cue, select the motor 
using either the Motor drop-down list or the select 
tool.  The motor will show a red outline when it is 
selected. 

k. Press the In Cue button. 
l. With Motor #1 still selected, click on the Set 

Target tool. 
m. Click anywhere on the virtual stage and drag to the 

right.  Notice how the motor’s target shadow 
moves along the winch track. 

n. Select a spot on the track around half way and 
release the mouse. 

o. In the Speed box enter a speed half of the 
maximum speed of the winch (in our example that 
would be 14.5 inches/second) 

p. In the Acceleration box enter a modest acceleration 
value, for this example let’s use 3 
inches/second/second. 

q. Click the Apply button to record the changes to 
Cue #1. 

r. Click the Copy Cue button 
s. Click Add Cue and enter a cue number of 2. 
t. Click the Paste Cue button. 
u. Select Cue #2 from the Load Cue drop-down list to 

load the newly pasted cue. 
v. Change the Target value to 0 and press Apply. 

Now we have two cues set up to move the motor, 
so let’s continue with the tuning process. 

2. Now select View>Motor Setup>Tuning. 
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3. Enter the following values: 

a. Proportional Gain = 1 
b. Derivative Gain = 100 
c. Sampling = 1 

4. Click Load Filter 
5. In the Stage Schematic window select Cue #1 from the 

Load Cue drop-down list. 
6. In View>Cue Controller press the Go button (looks like a 

“play” button) and observe the motor moving. 

 
7. If the motor doesn’t complete the move all the way to the 

target, increase Proportional Gain by 10. 
8. Click Load Filter. 
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9. Select Cue #2 from the Load Cue drop-down list and press 
Go on the cue controller. 

10. If the motor doesn’t complete the move all the way to the 
target repeat steps 7 & 8 until it does.  There will often be 
a slight error in the final position of the motor, but it 
should be able to reach its target within .125”.  If the 
motor starts jerking back and forth during its move, start 
reducing the Proportional Gain by 1 until the cue runs 
smoothly. 

11. Run a cue again and listen to the motor during the 
acceleration. 

12. If the motor is “chugging” during the acceleration, 
increase the Sampling by 1 and run a cue to test the 
progress.  Repeat until the “chugging” is minimal. 

13. Double the Derivative Gain and run a cue.  Keep doubling 
until the “chugging” comes back. 

14. Reduce the Derivative Gain by 50 until the “chugging” is 
minimal. 

That’s it!  As you get a feel for the tuning parameters you can 
experiment more to find optimal settings for your setup.  Under 
normal circumstances, tuning should take no more than half an hour.  
The general rules of thumb are: 

1. The higher the Proportional Gain the more accurate the motor 
will be.  If the Proportional Gain is too high the motor will 
jerk back and forth. 

2. The higher the Derivative Gain the more precise the motor will 
be during changes in speed (acceleration) and changes in 
loading.  If the Derivative Gain is too high you will notice 
chugging in the acceleration of the motor. 

3. Sampling works with Derivative Gain to increase accuracy 
during changes in speed and loading. 

 

4.2.7 –Setting Max Position Error 
Once you have your motor tuned as best as you can, it is a good idea 
to set the Max Position Error.  This setting lets Avista shut down a 
motor if it is getting too far off its target at any time during a 
movement.  This will prevent a run-away motor if the encoder 
becomes disconnected from the shaft of the motor, or if the encoder 
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breaks.  It also can help minimize the damage if a piece of scenery 
hits an obstruction. 
 
Max Position Error should be low enough to help prevent accidents, 
yet high enough that it doesn’t shut down a motor just because it is 
poorly tuned or has some slop in the mechanics.  So the better the 
tuning of the motor, the lower the value can be in the Max Position 
Error.  Let’s try it out: 

1. Select View>Motor Setup>Properties 
2. Click on the check box next to Max Position Error, this is the 

allowable margin of error in motor movement.  This enables 
Avista to shutdown a motor when the programmed position 
error is reached. 

3. Enter a value for the Position Error.  This value will be in the 
same scale that you are using for the motor (i.e. inches, 
degrees, etc.)  Start low (1 inch or .25 degrees) 

4. Click Apply 
5. Run a cue and see if Avista shuts the motor down mid- cue.  If 

it does, either tighten up the tuning (without Max Position 
Error box checked) or raise the Max Position Error limit until 
you can complete the cue.  Note:  If Avista stops the motor on 
a Position Error fault, you must press the Stop button on the 
Cue Control before re-loading a cue and trying again. 

4.3 –Writing Cues 
There are two ways to write cues in Avista, using the Cue 
Spreadsheet or using the Stage Schematic.  We will run through an 
example using both methods utilizing the same two motors that we 
configured in the previous section. 

4.3.1 – Writing Cues in the Cue Spreadsheet 
Writing cues in the Cue Spreadsheet may be a more familiar interface 
to anyone who has worked with other automation systems.  Cues and 
motors are laid out in a grid, similar to what you would find in a 
program like Microsoft Excel.  The columns are cues, and the rows 
are motors.  To enter or edit any cue just click on the spreadsheet cell 
and type in a new value.  Let’s try it out. 

1. Select View>Cue Spreadsheet 
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2. If you wrote cues to help in the tuning process you’ll see them 
in the spreadsheet, if not you should see the motors in the 
show listed on the left and no cues for them. 

3. Click on the Add Cue button and enter a cue number of 10 and 
click OK.  Tip:  It’s often good practice to start writing cues 
at 10 or 100 to leave room for preset cues or spike cues. 

4. A new column with a heading of 10 should have appeared.  
Currently no motors are included in the cue, so there aren’t 
any values under cue 10. 

5. Under the cue 10 column, enter some values for Motor 1: 
a. Enter a Position that is half of the Forward Limit.  In 

this example I used 150.  Motor #1 is scaled in inches, 
so this target position is a 150 inches. 

b. Enter a Speed that is half of the Maximum Speed.  In 
this example I used 14.5.  Motor #1 is scaled in inches, 
so this Speed is 14.5 inches/second. 

c. Enter an Acceleration that is a quarter of the Maximum 
Speed.  In this example I used 7.25.  Motor #1 is 
scaled in inches, so this Acceleration is 7.25 
inches/second/second.  Note:  Depending on the 
resolution of your encoder, not all speed and 
acceleration values are possible.  Avista will 
automatically compute the nearest value and write that 
into the cue.  This can be disconcerting when you first 
see the number you entered not “stick”, but it lets you 
know what is actually achievable.  To increase your 
control on acceleration and speed, you need to 
increase the resolution on your encoder. 

6. To add Motor #2 to the cue, enter in some cue values under 
cue 10.  Make sure these motors don’t run the risk of bumping 
into each other. 

That’s all there is to it.  Now let’s try out some of the editing features 
of the spreadsheet as we make another cue. 

1. Click on the Add Cue button and enter a cue number of 11. 
2. We want to create a cue that returns both motors to Position 0 

at the same speed and acceleration of cue 10.  To do this will 
use copy/paste.  Select from Motor #1 Position through Motor 
#2 Acceleration.   Select Edit>Copy 

3. Click on Motor #1 Position under Cue 11. 
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4. Select Edit>Paste 
5. You should now have a copy of Cue #10 in Cue #11. 
6. Change both position values to 0. 

Let’s say you decide that you actually want Cue #11 split into two 
cues so that you can stagger the motion of Motor #1 & Motor #2. 

1. Click Add Cue and enter 11.5. 
2. Select from Motor #2 Position to Motor #2 Acceleration under 

Cue 11. 
3. Press Ctrl + C to copy the movement. 
4. Select the Position cell for Motor #2 under cue 11.5 
5. Press Ctrl + V to paste the movement into cue 11.5 
6. To delete Motor #2 from cue #11, click on the status cell for 

Motor #2 under Cue 11 and press Backspace.  When the 
dialog asks you to confirm the deletion, click OK. 

Now you should have to separate cues that bring the motors home.  
Later on we’ll look at how you can link these cues together to have 
Cue #11.5 automatically follow Cue #11. 

4.3.2 –Writing Cues in the Stage Schematic 
Avista’s Stage Schematic makes writing cues very intuitive.  The 
Stage Schematic presents a virtual stage in plan view where you can 
position targets for every motor and get a visual representation of the 
cue you are writing.  If you haven’t already configured your motors 
and stage for the schematic view, go back to the section Settings for 
Stage Schematic. 

1. Select View>Stage Schematic 
2. Click the Add Cue button; enter 12 for the cue number. 
3. Select Cue #12 from the Load Cue drop-down list. 
4. Select Motor #1 using either the Select tool, or the Motor 

drop-down list. 
5. Click the In Cue button so that it is depressed. 
6. Using the Set Target tool click and drag on the stage.  As you 

drag right the target shadow for Motor #1 increases its 
position.  Dragging to the left will decrease the target position.  
Pick a spot for the target and release the mouse. 

7. Enter speed and acceleration values into the Speed and Accel 
boxes.  Use similar values to those you used in the 
spreadsheet. 

8. Use the Select tool to select Motor #2. 



Avista Software Manual 

Page 48 

9. Repeat step 5-7 for Motor #2. 
10. Click Apply. 

Suppose you want to remove Motor #1 from Cue #12. 
1. Select Cue #12 from the Load Cue drop down list 
2. Select Motor #1 using either the Select tool or the Motor drop-

down list. 
3. Click on the In Cue button, so that it is released. 
4. Click Apply. 

4.3.3 – Linking Cues 
Avista makes it easy to link multiple cues together that create 
complex motions.  In this example we’ll link a couple of cues 
together and explore the different link options.  We’ll link together 
cues 11 & 11.5 so that cue 11.5 begins when Motor #1 reaches 
position 75”. 

1. Select View>Cue Sheet 
2. Click on Cue #11.5 and drag it onto Cue #11.  As you drag 

you’ll see the cursor change to a chain link, this lets you know 
that you will link two cues together.   

3. Drop Cue #11.5 on Cue #11.  Cue 11.5 is now indented 
underneath Cue #11. 

4. Click on Cue #11.5 
5. In the Cue Properties pane select Position Trigger from the 

drop-down list. 
6. Make sure Motor 1 is selected in the Motor drop-down list. 
7. Enter 75 in the trigger parameter box and press Enter. 
8. Run Cue #11 and witness how Cue #11.5 automatically 

executes. 
To change the type of link, just select either Time Trigger or 
Completion from the link type drop-down list. 
 
If you want to break the link between the two cues you can either: 

1. Select Cue #11.5 and press the Break Link button 
Or 
2. Select Cue #11.5 and select Independent from the link type 

drop-down list. 
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4.4 – Running a show 
Now that we have written some cues, let’s discuss how you run a 
show.  Though there are different ways to accomplish each task, 
running a show consists of loading cues and executing cues. 

4.4.1 – Loading Cues 
Loading a cue sends all of the movement information for each motor 
and sends it to each Stagehand that will be moving in the cue. 
To load a cue you can: 

1. Double-click on a cue in the Cue Sheet. 
2. Double-click on a cue column in the Cue Spreadsheet. 
3. Select a cue from the Load Cue drop-down list on the Stage 

Schematic. 
4. Linked cues will automatically load themselves when 

appropriate. 
5. Using either the on-screen Cue Control or the USB 

ShowStopper: 
a. Press the Load Cue button and enter a cue number. 
b. Use the Next Cue or Previous Cue button to step 

through the show sequentially. 
You can a load a cue at any time even while another cue is running.  
This allows for “pile on” cueing, which means that you can manually 
run multiple cues with staggered starts.  This is helpful if you have 
two cues that overlap, but the timing of the cues isn’t consistent 
enough for a linked cue.  Examples are if a series of cues are timed 
with an actor’s dialogue or position on stage.  Note:  If you load a cue 
that has movement information for a motor that is currently moving, 
that motor will be stopped in preparation for its next move.   
 

4.4.2 – Running Cues 
To run a cue, the cue must be loaded first.  Then press the Go button 
on either the on-screen cue control or the Go button of the USB 
ShowStopper.  Linked cues will run automatically. 
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5 – Troubleshooting 
Though the combination of Avista, Stagehand, and Showstopper 
strives to make automation easy, there are certainly times when things 
don’t work.  This part of the guide will give you some earned advice 
about what to culprits to look for when motors refuse to move. 

Motor won’t run in cue. 
Try moving the motor with the jog controls on the Stagehand. 

Motor won’t run with jog controls. 
Check the power being supplied to the Stagehand. 
Check the LCD status display on the Stagehand. 

o E-Stop! – Either the Showstopper is activated, or the 
Stagehand isn’t connected to the Showstopper so check 
your cables. 

o Forward Limit – The motor is sitting on the limit switch, 
so you won’t be able to move forward.  Or the limit switch 
is unplugged or wired incorrectly.   Limit switches need to 
be wired normally closed (n.c.) 

o Reverse Limit – Same as Forward Limit. 
o Both Limits – Either you’ve engaged both limits and need 

to move one, or the limits aren’t plugged in (or they’re 
wired incorrectly). 

 Meter the voltage coming out of the Motor Power socket on the 
Stagehand as you use the jog controls.  If you have a 120vac 
input you should see 90vdc output, 230vac input you should 
see 180vdc output. 

Meter the voltage coming out of the brake socket, you should see 
either 120vac or 230vac as soon as you press either jog 
direction button. 

If you aren’t getting motor voltage, check the internal fuses in the 
Stagehand (see Stagehand owner’s manual for details) 

Motor runs fine with jog controls, but won’t run from 
Avista. 

Check the Stagehand LCD’s network status.  Connected means it 
is communicating with your PC, Not Connected means there 
is either a break in the network cabling or Avista hasn’t 
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connected to the Stagehand.  Use the Motor Setup to connect 
to the Stagehand. 

Make sure you have a tuning filter loaded.  From the Motor 
Setup>Tuning click Load Filter. 

If the motor stopped in the middle of a cue and now won’t restart, 
chances are that Avista shut down the motor because it 
exceeded the Max. Position error.  Press the Stop button on 
Cue Control or Showstopper and then try to reload the cue. 

When running a cue, the motor speeds fast in the 
wrong direction and then turns off. 

1. The polarity of the motor is reversed.  Open up the motor plug 
and switch the white and black wire. 

When running a cue, the motor speeds fast in the 
right direction and then turns off. 

1. Check to make sure that the encoder is still attached to the 
motor securely. 

2. Check the encoder connector. 

Technical Support 
Though we try our best to produce reliable software and clear 
instructions, there may come a time when you need personal support. 

Phone Support 
You can call our technical support at 401-862-2980 Monday-
Saturday from 8am – 6pm EST.  Phone support is free for 90 days, 
after that a rate of $30/hr. applies to support calls. 

Web Support 
There is an active user support forum on our website.  
http://www.creativeconners.com/phpBB2/index.php 

Email 
If you have a technical question you can email technical support 
support@creativeconners.com. 
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Bugs 
If you think you have found an “undocumented feature”, we want to 
know!  Though we wish Avista was flawless, the next best thing is to 
fix problems as soon as they arise.  Please send any bug reports to 
support@creativeconners.com and check our website for any patches 
or updates www.creativeconners.com. 
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